Historical Data Slowdown

Incident Report for TankLogix

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 17:56 CST

Update

Historical data has been caught up for some time now, but we continue to monitor the situation
Posted Mar 03, 2026 - 15:11 CST

Monitoring

We have identified a slowdown with historical data are working to resolve the issue.
Posted Mar 03, 2026 - 13:33 CST
This incident affected: Historical Data.